summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-09-14 17:42:16 +0200
committerChristian Grothoff <christian@grothoff.org>2019-09-14 17:42:16 +0200
commit4cc86b52d215b1d56368403ab0faccd92f701336 (patch)
treeafcf29a91dbf50411cf9d4baf21611bb8bd0e180 /configure.ac
parent9a8ad855a1b7876f3e165c4caf7733e41762f3b2 (diff)
downloadexchange-4cc86b52d215b1d56368403ab0faccd92f701336.tar.gz
exchange-4cc86b52d215b1d56368403ab0faccd92f701336.tar.bz2
exchange-4cc86b52d215b1d56368403ab0faccd92f701336.zip
add --enable-sanitizer
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b58b1f8..a40dfb6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -447,6 +447,12 @@ AC_ARG_ENABLE(linker-hardening,
[AS_IF([test x$enableval = xyes],[LDFLAGS="$LDFLAGS -z relro -z now"])])
+AC_ARG_ENABLE(sanitizer,
+ AS_HELP_STRING(--enable-sanitizer, enable Address Sanitizer and Undefined Behavior Sanitizer),
+[AS_IF([test x$enableval = xyes],[
+ LDFLAGS="$CFLAGS -fsanitize=address,undefined -fno-omit-frame-pointer"
+ ])])
+
# logging
extra_logging=0
AC_ARG_ENABLE([logging],