summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-03-08 22:53:35 +0100
committerChristian Grothoff <christian@grothoff.org>2024-03-08 22:53:35 +0100
commit19c368fc47192f44d1cf9e651d9360c4546b2807 (patch)
treec750e3a06119aa27b00c54890e5db09b1e1d0f4b /configure.ac
parent1beb3e72899aea2ca0b8cf3855be94575d7977c0 (diff)
downloadexchange-19c368fc47192f44d1cf9e651d9360c4546b2807.tar.gz
exchange-19c368fc47192f44d1cf9e651d9360c4546b2807.tar.bz2
exchange-19c368fc47192f44d1cf9e651d9360c4546b2807.zip
implement protocol v19 in taler-exchange-httpd (for #8000); note that taler-exchange-offline support is still missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index dc9b00a5c..e5675a732 100644
--- a/configure.ac
+++ b/configure.ac
@@ -182,7 +182,7 @@ AC_CHECK_HEADERS([gnunet/gnunet_util_lib.h],
AS_IF([test $libgnunetutil != 1],
[AC_MSG_ERROR([[
***
-*** You need libgnunetutil >= 0.21.0 to build this program.
+*** You need libgnunetutil >= 0.21.1 to build this program.
*** This library is part of GNUnet, available at
*** https://gnunet.org
*** ]])])
@@ -300,14 +300,13 @@ AS_CASE([$with_gnunet],
CPPFLAGS="-I$with_gnunet/include ${CPPFLAGS}"])
CPPFLAGS="${CPPFLAGS} ${POSTGRESQL_CPPFLAGS}"
AC_CHECK_HEADERS([gnunet/gnunet_pq_lib.h],
- [AC_CHECK_LIB([gnunetpq], [GNUNET_PQ_get_event_notify_channel], libgnunetpq=1)])
+ [AC_CHECK_LIB([gnunetpq], [GNUNET_PQ_query_param_int64], libgnunetpq=1)])
AS_IF([test $libgnunetpq != 1],
[AC_MSG_ERROR([[
***
-*** You need libgnunetpq version >= 5:0:0 to build this program.
+*** You need libgnunetpq version >= 6:0:1 to build this program.
*** Make sure you have Postgres installed while
-*** building GNUnet (and that your GNUnet version
-*** is recent!)
+*** building GNUnet (and that your GNUnet version is recent!)
*** ]])])
CFLAGS_SAVE=$CFLAGS