summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-04-24 09:33:58 +0000
committerng0 <ng0@n0.is>2019-04-24 09:34:07 +0000
commitf5099e863f719b406ea2ab0a8b51279fc6455a4c (patch)
tree4df1938cce79f788e81b7b45770653a835ec9a2c /configure.ac
parentce43aa22cdf167c4d2bd4ac71523c63d80989c51 (diff)
downloadbank-f5099e863f719b406ea2ab0a8b51279fc6455a4c.tar.gz
bank-f5099e863f719b406ea2ab0a8b51279fc6455a4c.tar.bz2
bank-f5099e863f719b406ea2ab0a8b51279fc6455a4c.zip
Revert "Attempt to detect more valid pip executables."
This reverts commit ce43aa22cdf167c4d2bd4ac71523c63d80989c51.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 2 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 0da5d9f..d70c52a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,46 +28,20 @@ PC_PYTHON_CHECK_HEADERS([pyheaders=1])
PC_PYTHON_CHECK_VERSION()
#
-# Check for pip3.
-# It is either pip3 or pip[3.4,3.5,3.6,3.7].
-# XXX: This check might be bad.
-# XXX: We might want to write proper m4 or an
-# XXX: external script for the pip detection and usage.
+# Check for pip3
#
AC_MSG_CHECKING([pip3])
pip3 --version >/dev/null
if test $? -ne 0;
then
- pip3.4 --version >/dev/null
- if test $? -ne 0;
- then
- pip3.5 --version >/dev/null
- if test $? -ne 0;
- then
- pip3.6 --version >/dev/null
- if test $? -ne 0;
- then
- pip3.7 --version >/dev/null
- if test $? -ne 0;
- then
- AC_MSG_ERROR([Please install pip3>=6.0])
-fi
-fi
-fi
-fi
+ AC_MSG_ERROR([Please install pip3>=6.0])
fi
PIP_VERSION=$(pip3 --version | $AWK '{ print $2 }')
-PIP_VERSION=$(pip3.4 --version | $AWK '{ print $2 }')
-PIP_VERSION=$(pip3.5 --version | $AWK '{ print $2 }')
-PIP_VERSION=$(pip3.6 --version | $AWK '{ print $2 }')
-PIP_VERSION=$(pip3.7 --version | $AWK '{ print $2 }')
AC_MSG_RESULT([$PIP_VERSION])
-# FIXME: Also check for equal 6.0? At this point 19.0 is out, so
-# checking for >6.0 should be enough.
AX_COMPARE_VERSION([$PIP_VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
# On Debian systems, we may need to pass "--system" to pip3 to get