summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-11-01 11:45:09 +0100
committerChristian Grothoff <christian@grothoff.org>2017-11-01 11:45:22 +0100
commitb5a78db2ea5aa2a9d889717e6d76438a0be09bfc (patch)
treeaa7575066069b99de0c95adf7cd7b4637f090e10 /configure.ac
parent7b8b462c2042a45fb69c337b1526aa34da18329f (diff)
downloadbank-b5a78db2ea5aa2a9d889717e6d76438a0be09bfc.tar.gz
bank-b5a78db2ea5aa2a9d889717e6d76438a0be09bfc.tar.bz2
bank-b5a78db2ea5aa2a9d889717e6d76438a0be09bfc.zip
modify configure to auto-detect --system on Debian
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 00619b2..8ba19af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,13 +43,12 @@ AX_COMPARE_VERSION([$PIP_VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3
# On Debian systems, we may need to pass "--system" to pip3 to get
# to the desired installation target directory
-AC_ARG_ENABLE(debian-system,
- AS_HELP_STRING(--enable-debian-system, pass --system option to pip3 to make Debian pip obey installation prefix),
-[if test x$enableval = xyes; then
- DEBIAN_PIP3_SYSTEM="--system"
-else
+pip3 install --help | grep '\-\-system' >> /dev/null
+if test $? -ne 0;
DEBIAN_PIP3_SYSTEM=""
-fi])
+else
+ DEBIAN_PIP3_SYSTEM="--system"
+fi
AC_SUBST(DEBIAN_PIP3_SYSTEM)
#