summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2016-04-19 15:43:14 +0200
committerFlorian Dold <florian.dold@gmail.com>2016-04-19 15:43:14 +0200
commit6d002e2105c82ce0fd03892af6b19e3626e0f2bc (patch)
tree1c0c07afa1dc0127c477a65f12d7a8bfd1aaee01 /configure.ac
parent1c789ccf6e44f2c34c09cfc2865be7d475db3629 (diff)
downloadbank-6d002e2105c82ce0fd03892af6b19e3626e0f2bc.tar.gz
bank-6d002e2105c82ce0fd03892af6b19e3626e0f2bc.tar.bz2
bank-6d002e2105c82ce0fd03892af6b19e3626e0f2bc.zip
use pyconfigure again
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 24aacd5..c6b7e9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,14 +5,11 @@ AC_CONFIG_MACRO_DIR([m4])
AC_PROG_AWK
AC_PROG_SED
-# PC_INIT([3.4])
-# Provisional check until pyconfigure gets fixed
-AC_MSG_NOTICE([Checking for python3])
-python3 --version > /dev/null
-if test $? -ne 0;
- then
- AC_MSG_ERROR([Please install python>=3.4])
-fi
+PC_INIT([3.5])
+
+#
+# Check for pip3
+#
AC_MSG_CHECKING([pip3])
pip3 --version >/dev/null
@@ -27,6 +24,10 @@ AC_MSG_RESULT([$VERSION])
AX_COMPARE_VERSION([$VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
+#
+# Check for PostgreSQL
+#
+
AC_MSG_NOTICE([Checking for PostgreSQL])
pg_config --version > /dev/null
if test $? -ne 0;
@@ -40,6 +41,9 @@ if test $? -ne 0;
AC_MSG_WARN([PostgreSQL present but 'psql' is not in $PATH])
fi
+#
+# Finish
+#
AC_CONFIG_FILES([Makefile])