summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-05-07 13:47:53 +0200
committerChristian Grothoff <christian@grothoff.org>2017-05-07 13:47:53 +0200
commit3645d943a4a8eaf5fa416a019b8ac4c2371c88a0 (patch)
tree7119efaf452bf275da92e7cd5f0d82de92f4c990 /configure.ac
parent4e687bb9024a17c5422a62628ac1a940fa14168e (diff)
downloadbank-3645d943a4a8eaf5fa416a019b8ac4c2371c88a0.tar.gz
bank-3645d943a4a8eaf5fa416a019b8ac4c2371c88a0.tar.bz2
bank-3645d943a4a8eaf5fa416a019b8ac4c2371c88a0.zip
add --enable-debian-system option to install bank to proper prefix even on Debian
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44d825f..92a401b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,17 @@ AC_MSG_RESULT([$PIP_VERSION])
AX_COMPARE_VERSION([$PIP_VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
+# On Debian systems, we may need to pass "--system" to pip3 to get
+# to the desired installation target directory
+AC_ARG_ENABLE(debian-system,
+ AS_HELP_STRING(--enable-debian-system, pass --system option to pip3 to make Debian pip obey installation prefix),
+[if test x$enableval = xyes; then
+ DEBIAN_PIP3_SYSTEM="--system"
+else
+ DEBIAN_PIP3_SYSTEM=""
+fi])
+AC_SUBST(DEBIAN_PIP3_SYSTEM)
+
#
# Check for PostgreSQL
#