summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2017-05-29 16:29:25 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-12 09:57:16 +0200
commitcb1ec7c930b8a84f29f689ea51a97a16b572485c (patch)
tree8d234ddc04173505447546d109eee73c448dbc5a /Makefile.am
parent400cd6b3915f0d516a18890bd34bb3d254645395 (diff)
downloadbank-cb1ec7c930b8a84f29f689ea51a97a16b572485c.tar.gz
bank-cb1ec7c930b8a84f29f689ea51a97a16b572485c.tar.bz2
bank-cb1ec7c930b8a84f29f689ea51a97a16b572485c.zip
comment
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 77f8528..5210094 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,7 @@ install-dev:
check:
@export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check-alt.conf" && python3 -m django test talerbank.app.tests_err
+ # This test only checks that the bank doesn't fail hard - no stack traces - if given a non exsistent config file
@export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="non-exsistent.conf" && if ! python3 -m django test talerbank.app.tests_err; then exit 0; else exit 1; fi
# @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check.conf" && python3 -m django test talerbank.app.tests