summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2017-12-28 12:38:55 +0100
committerMarcello Stanisci <stanisci.m@gmail.com>2017-12-28 12:38:55 +0100
commitb630970b2417ba84184febb92d4a12d762c9a237 (patch)
treed2ffabc268baf6bde4d53b642188bec09605231c /Makefile.am
parent8f51ca5748c5bf42eb36209f2ff887ff19823827 (diff)
downloadbank-b630970b2417ba84184febb92d4a12d762c9a237.tar.gz
bank-b630970b2417ba84184febb92d4a12d762c9a237.tar.bz2
bank-b630970b2417ba84184febb92d4a12d762c9a237.zip
script installation path directive
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index bc94a1c..efa1f63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,10 +102,12 @@ check:
# install into prefix
install-exec-hook:
@pip3 install . @DEBIAN_PIP3_SYSTEM@ \
- --target="${PYTHONPATH_APPEND}"
+ --target="${PYTHONPATH_APPEND}" \
+ --install-option="--install-scripts=@prefix@/bin"
@# force update when sources changed
@pip3 install . --target="${PYTHONPATH_APPEND}" \
- @DEBIAN_PIP3_SYSTEM@ --upgrade --no-deps
+ @DEBIAN_PIP3_SYSTEM@ --upgrade --no-deps \
+ --install-option="--install-scripts=@prefix@/bin"
pylint:
@pylint --load-plugins pylint_django talerbank/