summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2017-12-26 17:17:03 +0100
committerMarcello Stanisci <stanisci.m@gmail.com>2017-12-26 17:17:03 +0100
commita7f000619d8efbec35f0de0fd8bbb4359f3eb1d5 (patch)
treef732478a5d4b5916ef8e8c40d83630ecd0c9c47f /Makefile.am
parent88bef48c1e5dc04d28f4bc26a42dadb27686bec0 (diff)
downloadbank-a7f000619d8efbec35f0de0fd8bbb4359f3eb1d5.tar.gz
bank-a7f000619d8efbec35f0de0fd8bbb4359f3eb1d5.tar.bz2
bank-a7f000619d8efbec35f0de0fd8bbb4359f3eb1d5.zip
also accepting database connection strings of the form
postgres:///dbname?host=/path/to/sockets/dir/.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 7085a44..e844785 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,7 +57,7 @@ check:
"Testing against bad db string"
@export DJANGO_SETTINGS_MODULE="talerbank.settings" \
TALER_PREFIX="@prefix@" \
- TALER_CONFIG_FILE="bank-check-alt-baddb.conf" \
+ export TALER_BANK_ALTDB="bad db string" \
&& python3 \
-m django test \
--no-input \
@@ -71,7 +71,7 @@ check:
&& python3 \
-m django test \
--no-input \
- talerbank.app.tests_alt.BadMaxDebtOptionTestCase
+ talerbank.app.tests_alt.BadMaxDebitOptionTestCase
@printf ${FMT} ${SEPARATOR} \
"Testing against no currency in config"
@export TALER_BASE_CONFIG="/tmp" \
@@ -87,7 +87,7 @@ check:
"Testing against db not found"
@export DJANGO_SETTINGS_MODULE="talerbank.settings" \
TALER_PREFIX="@prefix@" \
- TALER_CONFIG_FILE="bank-check-alt-dbnotfound.conf" \
+ TALER_BANK_ALTDB="postgres:///idontexist" \
&& python3 ./taler-bank-manage serve-uwsgi ; \
test 4 = $$?