summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-12 13:04:04 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-12 13:04:04 +0200
commita567e252fa1467764591fccc78a74d7cd5488bd5 (patch)
treef30ebba888168de53335fab7ad23f0157595521f /Makefile.am
parente9bb1a6626eafa162efdb24817073c1b9755eee0 (diff)
downloadbank-a567e252fa1467764591fccc78a74d7cd5488bd5.tar.gz
bank-a567e252fa1467764591fccc78a74d7cd5488bd5.tar.bz2
bank-a567e252fa1467764591fccc78a74d7cd5488bd5.zip
run tests with non existent config file and NOT crash
the 'make check' command.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3538c3a..37268e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,7 @@ install-dev:
# The wrapper catches very hard errors (like no DB in place). Can the wrapper-less way catch those errors as well?
check:
@export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check.conf" && python3 run_tests.py
+ @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="non-existent.conf" && python3 run_tests.py || true
# install into prefix
install-exec-hook: