summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-13 11:42:18 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-13 11:42:18 +0200
commit8f55fe3c49bfc1ed6e1774a1d82ea65160ba0c64 (patch)
tree1f65406a2f5ed141a2554b57af84d4739764676e /Makefile.am
parent5b8a6f333c17197ddf79ff9ca0218b609933a5e3 (diff)
downloadbank-8f55fe3c49bfc1ed6e1774a1d82ea65160ba0c64.tar.gz
bank-8f55fe3c49bfc1ed6e1774a1d82ea65160ba0c64.tar.bz2
bank-8f55fe3c49bfc1ed6e1774a1d82ea65160ba0c64.zip
remove superfluous code
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index dd1deea..bd561be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,13 +23,12 @@ pkgdata_DATA = \
install-dev:
@$(PYTHON) ./install-dev.py
-# The wrapper is meant to catch hard errors (like no DB in place). Can the wrapper-less way catch those errors as well?
check:
- @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check.conf" && python3 run_tests.py
+ @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check.conf" && python3 -m django test talerbank.app.tests
@printf -- "\n\n----------------------------------------------------------------------\nTesting against non existent config file\n\n"
- @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="non-existent.conf" && python3 run_tests.py || true
+ @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="non-existent.conf" && python3 -m django test talerbank.app.tests ; test 3 = $$?
@printf -- "\n\n----------------------------------------------------------------------\nTesting against bad db string\n\n"
- @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check-alt-baddb.conf" && python3 run_tests_alt_dbstring.py ; test 2 = $$?
+ @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check-alt-baddb.conf" && python3 -m django test talerbank.app.tests_alt.BadDatabaseStringTestCase ; test 2 = $$?
# install into prefix
install-exec-hook: