summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2017-04-22 16:21:53 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2017-04-22 16:21:53 +0200
commit6c9203e4916a13d0de9fbc338b650200c6301d20 (patch)
tree330129c1cf193ed153bcbd9a31f0fbf4acfc6f38 /Makefile.am
parent5d52ca29b0659c62bf09891eed5071247ebaa76d (diff)
downloadbank-6c9203e4916a13d0de9fbc338b650200c6301d20.tar.gz
bank-6c9203e4916a13d0de9fbc338b650200c6301d20.tar.bz2
bank-6c9203e4916a13d0de9fbc338b650200c6301d20.zip
Reintroducing fixes from #4603, as regressions appeared.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 21d25d0..ceb8171 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ pkgdata_DATA = \
# link package under prefix to source tree
install-dev:
- @pip3 install -e . --install-option="--prefix=@prefix@"
+ @pip3 install -e . --install-option="--prefix=@prefix@" --system
check:
@export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" && python3 -m django test talerbank.app.tests
@@ -28,9 +28,9 @@ check:
# install into prefix
install-exec-hook:
- @pip3 install . --install-option="--prefix=@prefix@"
+ @pip3 install . --install-option="--prefix=@prefix@" --system
@# force update when sources changed
- @pip3 install . --install-option="--prefix=@prefix@" --upgrade --no-deps
+ @pip3 install . --install-option="--prefix=@prefix@" --upgrade --no-deps --system
app:
@tar czf taler-bank-$(PACKAGE_VERSION)-app.tgz `cat INCLUDE.APP`