summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-13 10:48:08 +0200
committerMarcello Stanisci <marcello.stanisci@inria.fr>2017-07-13 10:48:08 +0200
commit59683284f998ca08ef1e7c14123bb11bfb22677a (patch)
treee646f9d072c1869a822e2d66d26fe67c961f9d33 /Makefile.am
parent1c74d4f111aabf9698af469c4eceb24954f05b7f (diff)
downloadbank-59683284f998ca08ef1e7c14123bb11bfb22677a.tar.gz
bank-59683284f998ca08ef1e7c14123bb11bfb22677a.tar.bz2
bank-59683284f998ca08ef1e7c14123bb11bfb22677a.zip
Testing against bad db string in config
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 37268e6..dd1deea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,10 +23,13 @@ pkgdata_DATA = \
install-dev:
@$(PYTHON) ./install-dev.py
-# The wrapper catches very hard errors (like no DB in place). Can the wrapper-less way catch those errors as well?
+# The wrapper is meant to catch hard errors (like no DB in place). Can the wrapper-less way catch those errors as well?
check:
@export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check.conf" && python3 run_tests.py
+ @printf -- "\n\n----------------------------------------------------------------------\nTesting against non existent config file\n\n"
@export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="non-existent.conf" && python3 run_tests.py || true
+ @printf -- "\n\n----------------------------------------------------------------------\nTesting against bad db string\n\n"
+ @export DJANGO_SETTINGS_MODULE="talerbank.settings" TALER_PREFIX="@prefix@" TALER_CONFIG_FILE="bank-check-alt-baddb.conf" && python3 run_tests_alt_dbstring.py ; test 2 = $$?
# install into prefix
install-exec-hook: