summaryrefslogtreecommitdiff
path: root/talermerchantdemos/blog/static/web-common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'talermerchantdemos/blog/static/web-common/Makefile.am')
-rw-r--r--talermerchantdemos/blog/static/web-common/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/talermerchantdemos/blog/static/web-common/Makefile.am b/talermerchantdemos/blog/static/web-common/Makefile.am
new file mode 100644
index 0000000..71c1d68
--- /dev/null
+++ b/talermerchantdemos/blog/static/web-common/Makefile.am
@@ -0,0 +1,51 @@
+# This Makefile.am is in the public domain
+EXTRA_DIST = \
+ style.css \
+ taler-wallet-lib.ts \
+ chrome-any.d.ts \
+ logo-2015-medium.png \
+ licensing.rst \
+ favicon-taler.ico \
+ dropdown-navbar.html \
+ lang.html \
+ lang.css \
+ lang.js \
+ dropdown-navbar_style.css \
+ dropdown-navbar_script.js \
+ taler-fallback.css \
+ tsconfig.json \
+ AUTHORS
+
+# Some file may be missing here...
+pkgdata_DATA = \
+ dropdown-navbar.html \
+ favicon-taler.ico \
+ logo-2015-medium.png \
+ style.css \
+ taler-wallet-lib.js
+
+all: taler-wallet-lib.min.js taler-wallet-lib.js.tar.gz taler-wallet-lib.js
+
+%.min.js: %.js
+ python3 -m jsmin $< > $@
+
+%.js.tar.gz: %.js
+ tar czf $@ $<
+
+taler-wallet-lib.js: taler-wallet-lib.ts chrome-any.d.ts
+if HAVE_TSC
+ tsc
+else
+ @echo
+ @if [ ! -f "$@" ] ; then \
+ echo "*** Error: typescript compiler 'tsc' is missing," \
+ "can't build" $@ ; \
+ echo ; \
+ exit 1 ; \
+ else \
+ echo "*** Warning: typescript compiler 'tsc' is missing," \
+ "using pre-build" $@ ; \
+ touch "$@"; \
+ fi
+ @echo
+endif