summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 00e70d9..6bc2447 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -13,7 +13,17 @@ bin_SCRIPTS = \
sync-config
EXTRA_DIST = \
- $(bin_SCRIPTS)
+ $(bin_SCRIPTS) \
+ sync-config.in
+
+edit_script = $(SED) -e 's,%libdir%,$(libdir),'g $(NULL)
+
+sync-config: sync-config.in
+ rm -f $@ $@.tmp && \
+ $(edit_script) $< >$@.tmp && \
+ chmod a-w+x $@.tmp && \
+ mv $@.tmp $@
+
lib_LTLIBRARIES = \
libsyncutil.la