summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-09-17 10:51:02 +0200
committerChristian Grothoff <christian@grothoff.org>2021-09-17 10:51:02 +0200
commit960ab5516bdfa9bedc79b7e62fea9fcc4dd3db58 (patch)
tree36300fc6510b6b3b0de82e3bd7ab6f12cb7178a7 /src/util/Makefile.am
parent6bccda792e3709e5f730b6b2360aa268f4c8d7e2 (diff)
downloadsync-960ab5516bdfa9bedc79b7e62fea9fcc4dd3db58.tar.gz
sync-960ab5516bdfa9bedc79b7e62fea9fcc4dd3db58.tar.bz2
sync-960ab5516bdfa9bedc79b7e62fea9fcc4dd3db58.zip
-fix sync-config and service file
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 00e70d9..6bc2447 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -13,7 +13,17 @@ bin_SCRIPTS = \
sync-config
EXTRA_DIST = \
- $(bin_SCRIPTS)
+ $(bin_SCRIPTS) \
+ sync-config.in
+
+edit_script = $(SED) -e 's,%libdir%,$(libdir),'g $(NULL)
+
+sync-config: sync-config.in
+ rm -f $@ $@.tmp && \
+ $(edit_script) $< >$@.tmp && \
+ chmod a-w+x $@.tmp && \
+ mv $@.tmp $@
+
lib_LTLIBRARIES = \
libsyncutil.la