summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6e92670
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from setuptools import setup, find_packages
+
+setup(name='talersurvey',
+ version='0.0',
+ description='Example survey site for GNU Taler',
+ url='git://taler.net/survey',
+ author='Marcello Stanisci',
+ author_email='stanisci.m@gmail.com',
+ license='GPL',
+ packages=find_packages(),
+ install_requires=["Flask>=0.10"],
+ package_data={
+ '':[
+ "survey/templates/*.html",
+ "survey/static/*.svg",
+ "survey/static/*.css",
+ "survey/static/*.js",
+ "survey/static/*.js.tar.gz",
+ "survey/static/web-common/*.png",
+ "survey/static/web-common/*.css",
+ "survey/static/web-common/*.js",
+ "survey/static/web-common/*.js.tar.gz",
+ "survey/static/web-common/*.html",
+ ]
+ },
+ scripts=['taler-merchant-survey'],
+ zip_safe=False)