summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58f5b5e..5e349d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,19 @@ if test $? -ne 0;
AC_MSG_ERROR([Please install pip3>=6.0])
fi
+# On Debian systems, we may need to pass "--system" to pip3 to get
+# to the desired installation target directory
+pip3 install --help | grep '\-\-system' >> /dev/null
+if test $? -ne 0;
+then
+ DEBIAN_PIP3_SYSTEM=""
+else
+ DEBIAN_PIP3_SYSTEM="--system"
+fi
+AC_SUBST(DEBIAN_PIP3_SYSTEM)
+
+
+
VERSION=$(pip3 --version | $AWK '{ print $2 }')
AC_MSG_RESULT([$VERSION])