summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-09-25 18:04:04 +0000
committerng0 <ng0@n0.is>2019-09-25 18:04:04 +0000
commit107efba7d60ff0a3d56b48661d70d5842395a836 (patch)
treea5b2d9d17bb5794fd5668be5f6734154e5d0acdd /configure.ac
parenteeff7dbd327d5e136ac9998b9f2e077a9e4a78a7 (diff)
parent498b14392f7f828af1a239d680da27b859f85033 (diff)
downloadsurvey-107efba7d60ff0a3d56b48661d70d5842395a836.tar.gz
survey-107efba7d60ff0a3d56b48661d70d5842395a836.tar.bz2
survey-107efba7d60ff0a3d56b48661d70d5842395a836.zip
Merge branch 'master' of git.taler.net:survey
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac79
1 files changed, 0 insertions, 79 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index 5e349d2..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,79 +0,0 @@
-AC_INIT([talerfrontends], [0.1.0], [taler-bug@gnunet.org])
-
-AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE
-AC_PROG_AWK
-AC_PROG_SED
-
-#
-# Check for Python
-#
-
-PC_INIT([3.4])
-pyheaders=0
-PC_PYTHON_CHECK_HEADERS([pyheaders=1])
-PC_PYTHON_CHECK_VERSION()
-
-#
-# Check for pip3
-#
-
-AC_MSG_CHECKING([pip3])
-pip3 --version >/dev/null
-if test $? -ne 0;
- then
- AC_MSG_ERROR([Please install pip3>=6.0])
-fi
-
-# On Debian systems, we may need to pass "--system" to pip3 to get
-# to the desired installation target directory
-pip3 install --help | grep '\-\-system' >> /dev/null
-if test $? -ne 0;
-then
- DEBIAN_PIP3_SYSTEM=""
-else
- DEBIAN_PIP3_SYSTEM="--system"
-fi
-AC_SUBST(DEBIAN_PIP3_SYSTEM)
-
-
-
-VERSION=$(pip3 --version | $AWK '{ print $2 }')
-
-AC_MSG_RESULT([$VERSION])
-
-AX_COMPARE_VERSION([$VERSION],[lt],[6.0], [AC_MSG_ERROR([Please install pip3>=6.0])])
-
-
-#
-# Check for tsc
-#
-AC_CHECK_PROG([tsc],[tsc],[yes],[no])
-AM_CONDITIONAL([HAVE_TSC], [test "x$tsc" = xyes])
-
-#
-# Check for minifier
-#
-AC_MSG_CHECKING([Checking for jsmin])
-python3 -m jsmin &> /dev/null
-if test $? -ne 0;
- then
- AC_MSG_ERROR([Please install Python3 module 'jsmin'])
-fi
-
-#
-# Report
-#
-if test x$pyheaders != x1; then
- AC_MSG_WARN([Python headers not installed, might be required to build uwsgi])
-fi
-
-
-#
-# Finish
-#
-
-AC_CONFIG_FILES([Makefile
- talersurvey/survey/static/web-common/Makefile])
-
-AC_OUTPUT