summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2019-03-27 18:41:02 +0100
committerMarcello Stanisci <stanisci.m@gmail.com>2019-03-27 18:41:02 +0100
commitf40114e5b56522890ffe7d9fab80dfc0fecf2ac2 (patch)
treedb51283e13cc9ebd7850010aedb9358074779812 /configure.ac
parent49c3ca55986228049dd5f23cca55bccc86b7af15 (diff)
downloadsurvey-f40114e5b56522890ffe7d9fab80dfc0fecf2ac2.tar.gz
survey-f40114e5b56522890ffe7d9fab80dfc0fecf2ac2.tar.bz2
survey-f40114e5b56522890ffe7d9fab80dfc0fecf2ac2.zip
fix pip3 invocation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58f5b5e..5e349d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,19 @@ if test $? -ne 0;
AC_MSG_ERROR([Please install pip3>=6.0])
fi
+# On Debian systems, we may need to pass "--system" to pip3 to get
+# to the desired installation target directory
+pip3 install --help | grep '\-\-system' >> /dev/null
+if test $? -ne 0;
+then
+ DEBIAN_PIP3_SYSTEM=""
+else
+ DEBIAN_PIP3_SYSTEM="--system"
+fi
+AC_SUBST(DEBIAN_PIP3_SYSTEM)
+
+
+
VERSION=$(pip3 --version | $AWK '{ print $2 }')
AC_MSG_RESULT([$VERSION])