diff options
Diffstat (limited to 'src/merchant/Makefile.am')
-rw-r--r-- | src/merchant/Makefile.am | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/src/merchant/Makefile.am b/src/merchant/Makefile.am new file mode 100644 index 00000000..701b3ee8 --- /dev/null +++ b/src/merchant/Makefile.am | |||
@@ -0,0 +1,52 @@ | |||
1 | AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS) | ||
2 | |||
3 | MERCHANT_DB = merchant_db.c merchant_db.h | ||
4 | bin_PROGRAMS = \ | ||
5 | taler-merchant-dbinit \ | ||
6 | taler-merchant-serve | ||
7 | |||
8 | taler_merchant_dbinit_SOURCES = \ | ||
9 | taler_merchant_dbinit.c \ | ||
10 | $(MERCHANT_DB) | ||
11 | taler_merchant_dbinit_LDADD = \ | ||
12 | -lpq \ | ||
13 | -lgnunetutil \ | ||
14 | -ltalerutil \ | ||
15 | -lgnunetpostgres | ||
16 | taler_merchant_dbinit_LDFLAGS = \ | ||
17 | $(POSTGRESQL_LDFLAGS) | ||
18 | |||
19 | check_PROGRAMS = \ | ||
20 | test-merchant \ | ||
21 | test-merchant-db | ||
22 | |||
23 | test_merchant_SOURCES = \ | ||
24 | merchant.c \ | ||
25 | test_merchant.c | ||
26 | test_merchant_LDADD = \ | ||
27 | -ltalerutil \ | ||
28 | -lgnunetutil | ||
29 | |||
30 | test_merchant_db_SOURCES = \ | ||
31 | $(MERCHANT_DB) \ | ||
32 | test_merchant_db.c | ||
33 | test_merchant_db_LDADD = \ | ||
34 | -ltalerutil \ | ||
35 | -lgnunetutil \ | ||
36 | -lgnunetpostgres \ | ||
37 | -lpq | ||
38 | |||
39 | taler_merchant_serve_SOURCES = \ | ||
40 | taler_merchant_serve.c \ | ||
41 | merchant.c merchant.h \ | ||
42 | $(MERCHANT_DB) | ||
43 | taler_merchant_serve_LDADD = \ | ||
44 | -lpq \ | ||
45 | -lgnunetutil \ | ||
46 | -lgnunetpostgres \ | ||
47 | -lmicrohttpd \ | ||
48 | -ltalermintapi \ | ||
49 | -ltalerutil \ | ||
50 | -ljansson | ||
51 | taler_merchant_serve_LDFLAGS = \ | ||
52 | $(POSTGRESQL_LDFLAGS) | ||