diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 45 |
1 files changed, 36 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac index d013ab2e..ed82e0e4 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -50,6 +50,42 @@ AS_IF([test $libgnunetutil != 1], | |||
50 | *** ]])]) | 50 | *** ]])]) |
51 | 51 | ||
52 | 52 | ||
53 | # check for libpq (postgresql) | ||
54 | AX_LIB_POSTGRESQL([9.3]) | ||
55 | AS_IF([test ! "$found_postgresql" = "yes"], | ||
56 | [AC_MSG_ERROR([[ | ||
57 | *** | ||
58 | *** You need postgresql / libpq to build this program. | ||
59 | *** ]])]) | ||
60 | |||
61 | |||
62 | # Check for Taler's libtalerpq | ||
63 | libtalerpq=0 | ||
64 | AC_MSG_CHECKING([for libtalerpq]) | ||
65 | AC_ARG_WITH(mint, | ||
66 | [AS_HELP_STRING([--with-mint=PFX], [base of Taler MINT installation])], | ||
67 | [AC_MSG_RESULT([given as $with_mint])], | ||
68 | [AC_MSG_RESULT(not given) | ||
69 | with_mint=yes]) | ||
70 | AS_CASE([$with_mint], | ||
71 | [yes], [], | ||
72 | [no], [AC_MSG_ERROR([--with-mint is required])], | ||
73 | [LDFLAGS="-L$with_mint/lib $LDFLAGS" | ||
74 | CPPFLAGS="-I$with_mint/include $CPPFLAGS $POSTGRESQL_CPPFLAGS"]) | ||
75 | AC_CHECK_HEADERS([taler/db_pq.h], | ||
76 | [AC_CHECK_LIB([talerpq], [TALER_DB_exec_prepared], libtalerpq=1)], | ||
77 | [], [#ifdef HAVE_GNUNET_PLATFORM_H | ||
78 | #include <gnunet/platform.h> | ||
79 | #endif]) | ||
80 | AS_IF([test $libtalerpq != 1], | ||
81 | [AC_MSG_ERROR([[ | ||
82 | *** | ||
83 | *** You need libtalerpq to build this program. | ||
84 | *** This library is part of the Taler MINT, available at | ||
85 | *** https://taler.net | ||
86 | *** ]])]) | ||
87 | |||
88 | |||
53 | # check for libmicrohttpd | 89 | # check for libmicrohttpd |
54 | microhttpd=0 | 90 | microhttpd=0 |
55 | AC_MSG_CHECKING([for microhttpd]) | 91 | AC_MSG_CHECKING([for microhttpd]) |
@@ -72,15 +108,6 @@ AS_IF([test $microhttpd = 0], | |||
72 | *** ]])]) | 108 | *** ]])]) |
73 | 109 | ||
74 | 110 | ||
75 | # check for libpq (postgresql) | ||
76 | AX_LIB_POSTGRESQL([9.3]) | ||
77 | AS_IF([test ! "$found_postgresql" = "yes"], | ||
78 | [AC_MSG_ERROR([[ | ||
79 | *** | ||
80 | *** You need postgresql / libpq to build this program. | ||
81 | *** ]])]) | ||
82 | |||
83 | |||
84 | # check for libjansson (Jansson JSON library) | 111 | # check for libjansson (Jansson JSON library) |
85 | jansson=0 | 112 | jansson=0 |
86 | AC_MSG_CHECKING([for jansson]) | 113 | AC_MSG_CHECKING([for jansson]) |