summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am20
1 files changed, 4 insertions, 16 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 8efc3987a..41afcc97f 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -1,5 +1,5 @@
# This Makefile.am is in the public domain
-AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS) $(POSTGRESQL_CPPFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS)
if USE_COVERAGE
AM_CFLAGS = --coverage -O0
@@ -31,15 +31,12 @@ libtalerutil_la_SOURCES = \
amount.c \
crypto.c \
util.c \
- json.c \
os_installation.c \
- plugin.c \
- wireformats.c
+ plugin.c
libtalerutil_la_LIBADD = \
-lgnunetutil \
$(LIBGCRYPT_LIBS) \
- -ljansson \
-lmicrohttpd $(XLIB)
libtalerutil_la_LDFLAGS = \
@@ -48,13 +45,11 @@ libtalerutil_la_LDFLAGS = \
TESTS = \
test_amount \
- test_crypto \
- test_json
+ test_crypto
check_PROGRAMS= \
test_amount \
- test_crypto \
- test_json
+ test_crypto
test_amount_SOURCES = \
@@ -68,10 +63,3 @@ test_crypto_SOURCES = \
test_crypto_LDADD = \
-lgnunetutil \
libtalerutil.la
-
-test_json_SOURCES = \
- test_json.c
-test_json_LDADD = \
- -lgnunetutil \
- -ljansson \
- libtalerutil.la