summaryrefslogtreecommitdiff
path: root/src/templating/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/templating/meson.build')
-rw-r--r--src/templating/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/templating/meson.build b/src/templating/meson.build
new file mode 100644
index 000000000..c7ecc8dfc
--- /dev/null
+++ b/src/templating/meson.build
@@ -0,0 +1,12 @@
+project('mustach', 'c',
+ version: '1.0.0'
+)
+
+mustach_inc = include_directories('.')
+mustach_lib = shared_library('mustach',
+ 'mustach.c',
+ include_directories: mustach_inc
+)
+
+mustach_dep = declare_dependency(link_with: mustach_lib,
+ include_directories: mustach_inc)