summaryrefslogtreecommitdiff
path: root/src/sq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sq/Makefile.am')
-rw-r--r--src/sq/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/sq/Makefile.am b/src/sq/Makefile.am
new file mode 100644
index 000000000..ee4c5eba7
--- /dev/null
+++ b/src/sq/Makefile.am
@@ -0,0 +1,40 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS) $(SQLITE_CPPFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libtalersq.la
+
+libtalersq_la_SOURCES = \
+ sq_query_helper.c \
+ sq_result_helper.c
+
+libtalersq_la_LIBADD = \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil -ljansson \
+ -lsqlite3 $(XLIB)
+
+libtalersq_la_LDFLAGS = \
+ $(SQLITE_LDFLAGS) \
+ -version-info 0:0:0 \
+ -export-dynamic -no-undefined
+
+TESTS = \
+ test_sq
+
+check_PROGRAMS= \
+ test_sq
+
+test_sq_SOURCES = \
+ test_sq.c
+test_sq_LDADD = \
+ libtalersq.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetsq \
+ -lgnunetutil \
+ -ljansson \
+ -lsqlite3 $(XLIB)