summaryrefslogtreecommitdiff
path: root/src/json/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/json/Makefile.am')
-rw-r--r--src/json/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/json/Makefile.am b/src/json/Makefile.am
new file mode 100644
index 000000000..6f71b8718
--- /dev/null
+++ b/src/json/Makefile.am
@@ -0,0 +1,38 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libtalerjson.la
+
+libtalerjson_la_SOURCES = \
+ json.c \
+ json_helper.c
+libtalerjson_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -export-dynamic -no-undefined
+libtalerjson_la_LIBADD = \
+ -lgnunetjson \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+TESTS = \
+ test_json
+
+check_PROGRAMS= \
+ test_json
+
+test_json_SOURCES = \
+ test_json.c
+test_json_LDADD = \
+ -ltalerjson \
+ -lgnunetjson \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil \
+ -ljansson