summaryrefslogtreecommitdiff
path: root/src/extensions/age_restriction/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/extensions/age_restriction/Makefile.am')
-rw-r--r--src/extensions/age_restriction/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/extensions/age_restriction/Makefile.am b/src/extensions/age_restriction/Makefile.am
new file mode 100644
index 000000000..bf5b2f5f5
--- /dev/null
+++ b/src/extensions/age_restriction/Makefile.am
@@ -0,0 +1,32 @@
+# This Makefile.am is in the public domain
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/include \
+ $(LIBGCRYPT_CFLAGS) \
+ $(POSTGRESQL_CPPFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+# Age restriction as extension library
+
+plugindir = $(libdir)/taler
+
+plugin_LTLIBRARIES = \
+ libtaler_extension_age_restriction.la
+
+libtaler_extension_age_restriction_la_LDFLAGS = \
+ $(TALER_PLUGIN_LDFLAGS) \
+ -no-undefined
+
+libtaler_extension_age_restriction_la_SOURCES = \
+ age_restriction.c
+libtaler_extension_age_restriction_la_LIBADD = \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)