summaryrefslogtreecommitdiff
path: root/src/exchange-tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchange-tools/Makefile.am')
-rw-r--r--src/exchange-tools/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/src/exchange-tools/Makefile.am b/src/exchange-tools/Makefile.am
index 82f4cbeb9..846ea6132 100644
--- a/src/exchange-tools/Makefile.am
+++ b/src/exchange-tools/Makefile.am
@@ -15,7 +15,8 @@ endif
bin_PROGRAMS = \
taler-auditor-offline \
taler-exchange-offline \
- taler-exchange-dbinit
+ taler-exchange-dbinit \
+ taler-crypto-worker
taler_exchange_offline_SOURCES = \
taler-exchange-offline.c
@@ -59,6 +60,20 @@ taler_exchange_dbinit_CPPFLAGS = \
-I$(top_srcdir)/src/pq/ \
$(POSTGRESQL_CPPFLAGS)
+taler_crypto_worker_SOURCES = \
+ taler-crypto-worker.c
+taler_crypto_worker_LDADD = \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ -lgnunetutil \
+ -lgnunetjson \
+ -ljansson \
+ -lpthread \
+ $(LIBGCRYPT_LIBS) \
+ $(XLIB)
+
+
+
# Testcases