summaryrefslogtreecommitdiff
path: root/src/auditordb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/auditordb/Makefile.am')
-rw-r--r--src/auditordb/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/auditordb/Makefile.am b/src/auditordb/Makefile.am
new file mode 100644
index 000000000..e8ec40272
--- /dev/null
+++ b/src/auditordb/Makefile.am
@@ -0,0 +1,53 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/pq/ $(POSTGRESQL_CPPFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+pkgcfgdir = $(prefix)/share/taler/config.d/
+
+pkgcfg_DATA = \
+ auditordb-postgres.conf
+
+EXTRA_DIST = \
+ auditordb-postgres.conf
+
+plugindir = $(libdir)/taler
+
+if HAVE_POSTGRESQL
+plugin_LTLIBRARIES = \
+ libtaler_plugin_auditordb_postgres.la
+endif
+
+libtaler_plugin_auditordb_postgres_la_SOURCES = \
+ plugin_auditordb_postgres.c
+libtaler_plugin_auditordb_postgres_la_LIBADD = \
+ $(LTLIBINTL)
+libtaler_plugin_auditordb_postgres_la_LDFLAGS = \
+ $(TALER_PLUGIN_LDFLAGS) \
+ $(top_builddir)/src/pq/libtalerpq.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lpq \
+ -lgnunetpq \
+ -lgnunetutil $(XLIB)
+
+lib_LTLIBRARIES = \
+ libtalerauditordb.la
+
+libtalerauditordb_la_SOURCES = \
+ auditordb_plugin.c
+
+libtalerauditordb_la_LIBADD = \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil $(XLIB)
+
+libtalerauditordb_la_LDFLAGS = \
+ $(POSTGRESQL_LDFLAGS) \
+ -version-info 0:0:0 \
+ -no-undefined
+
+
+EXTRA_test_auditordb_postgres_DEPENDENCIES = \
+ libtaler_plugin_auditordb_postgres.la