summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a2d3ebcd9..e3a17f723 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,9 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = include util pq mintdb mint mint-tools mint-lib
+if HAVE_POSTGRESQL
+ PQ_DIR = pq
+endif
+SUBDIRS = include util $(PQ_DIR) mintdb mint mint-tools
+if HAVE_LIBCURL
+ SUBDIRS += mint-lib
+endif