summaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am54
1 files changed, 52 insertions, 2 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index f9de7a75e..eb4ad312d 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -1,12 +1,62 @@
-SUBDIRS = . tos pp
+SUBDIRS = .
+
+# English (en)
+tosendir=$(pkgdatadir)/tos/en
+
+# English (en)
+ppendir=$(pkgdatadir)/pp/en
+
+tosen_DATA = \
+ tos/en/0.txt \
+ tos/en/0.pdf \
+ tos/en/0.epub \
+ tos/en/0.xml \
+ tos/en/0.html
+
+ppen_DATA = \
+ pp/en/0.txt \
+ pp/en/0.pdf \
+ pp/en/0.epub \
+ pp/en/0.xml \
+ pp/en/0.html
bin_SCRIPTS = \
- taler-bank-manage-testing
+ taler-bank-manage-testing \
+ taler-exchange-revoke
EXTRA_DIST = \
$(bin_SCRIPTS) \
+ $(tosen_DATA) \
+ update-tos.sh \
+ update-pp.sh \
+ tos/Makefile \
+ tos/README \
+ tos/tos.rst \
+ tos/conf.py \
+ tos/locale/de/LC_MESSAGES/tos.po \
+ pp/Makefile \
+ pp/README \
+ pp/tos.rst \
+ pp/conf.py \
+ pp/locale/pp/LC_MESSAGES/pp.po \
auditor-report.tex.j2 \
coverage.sh \
gnunet.tag \
microhttpd.tag \
render.py
+
+# Change the set of supported languages here. You should
+# also update tos'XX'data and EXTRA_DIST accordingly.
+TOS_LANGUAGES="en de"
+PP_LANGUAGES="en de"
+
+# Change the terms-of-service version (Etag) to generate here!
+# This value should be incremented whenever there is a substantive
+# change in the original text (but not for the translations).
+TOS_VERSION=0
+PP_VERSION=0
+
+update-tos:
+ VERSION=$(TOS_VERSION) ./update-tos.sh $(TOS_LANGUAGES)
+update-pp:
+ VERSION=$(PP_VERSION) ./update-pp.sh $(PP_LANGUAGES)