summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a64cbff7..ccb0c1f31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,6 +199,10 @@ TALER_PLUGIN_LDFLAGS="-export-dynamic -avoid-version -module -no-undefined"
AC_SUBST(TALER_LIB_LDFLAGS)
AC_SUBST(TALER_PLUGIN_LDFLAGS)
+CFLAGS_SAVE=$CFLAGS
+LDFLAGS_SAVE=$LDFLAGS
+LIBS_SAVE="$LIBS"
+
AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
@@ -249,6 +253,10 @@ then
fi
fi
+CFLAGS=$CFLAGS_SAVE
+LDFLAGS=$LDFLAGS_SAVE
+LIBS=$LIBS_SAVE
+
# should developer logic be compiled (not-for-production code)?
AC_MSG_CHECKING(whether to compile developer logic)