summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 17a756020..8cdfa4ccf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,15 +191,14 @@ LIBS_SAVE=$LIBS
LIBGNURL_CHECK_CONFIG(,7.34.0,gnurl=1,gnurl=0)
LIBCURL_CHECK_CONFIG(,7.34.0,[curl=1],[curl=0])
-if test "x$curl" = x1
-then
+AS_IF([test "x$curl" = x1],[
AC_CHECK_HEADER([curl/curl.h],
AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=1],[curl=0],[[#include <curl/curl.h>]]),
[curl=0])
# need libcurl-gnutls.so, everything else is not acceptable
AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=0])
# cURL must support CURLINFO_TLS_SESSION, version >= 7.34
-fi
+])
# libcurl and libgnurl should be mutually exclusive
AS_IF([test "$gnurl" = 1],