summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4bbc20821..a73d4d863 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,19 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = src doc
+
+if DOC_ONLY
+ SUBDIRS = . doc
+else
+ SUBDIRS = . src doc
+endif
+
+@DX_RULES@
+
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = \
AUTHORS \
- contrib/coverage.sh
+ contrib/coverage.sh \
+ Doxyfile
app:
mkdir -p $(PACKAGE)-$(VERSION)-app