summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d62e19a50..d2e8d8e05 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,19 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = . contrib src doc
+if DOC_ONLY
+if ENABLE_DOC
+ SUBDIRS = . contrib doc
+else
+ SUBDIRS = . contrib
+endif
+else
+if ENABLE_DOC
+ SUBDIRS = . contrib src doc
+else
+ SUBDIRS = . contrib src
+endif
+endif
BUILT_SOURCES = src/include/taler_error_codes.h