summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ab0f3acc4..2499efb6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,9 +2,17 @@
AM_CPPFLAGS = -I$(top_srcdir)/src/include
if DOC_ONLY
+if ENABLE_DOC
SUBDIRS = . doc
else
+ SUBDIRS = .
+endif
+else
+if ENABLE_DOC
SUBDIRS = . src doc
+else
+ SUBDIRS = . src doc
+endif
endif
@DX_RULES@