summaryrefslogtreecommitdiff
path: root/src/wire/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-05-16 18:56:10 +0200
committerChristian Grothoff <christian@grothoff.org>2017-05-16 18:56:10 +0200
commitfc48947e32670864a5fac44a73df51433f4fdee8 (patch)
treeb46ee4d0d9f50de26c3ac92bf0dc5670d1302b08 /src/wire/Makefile.am
parent5447ad86ccb134760fa826c114ce2a8e765af988 (diff)
downloadexchange-fc48947e32670864a5fac44a73df51433f4fdee8.tar.gz
exchange-fc48947e32670864a5fac44a73df51433f4fdee8.tar.bz2
exchange-fc48947e32670864a5fac44a73df51433f4fdee8.zip
skeleton for the test for #4959
Diffstat (limited to 'src/wire/Makefile.am')
-rw-r--r--src/wire/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/wire/Makefile.am b/src/wire/Makefile.am
index 7bea7c8c6..da1b8b598 100644
--- a/src/wire/Makefile.am
+++ b/src/wire/Makefile.am
@@ -16,7 +16,8 @@ pkgcfg_DATA = \
EXTRA_DIST = \
wire-sepa.conf \
wire-test.conf \
- test_wire_plugin.conf
+ test_wire_plugin.conf \
+ test_wire_plugin_transactions_test.conf
plugindir = $(libdir)/taler
@@ -83,8 +84,8 @@ TESTS = \
check_PROGRAMS= \
test_sepa_wireformat \
- test_wire_plugin
-
+ test_wire_plugin \
+ test_wire_plugin_transactions_test
test_sepa_wireformat_SOURCES = \
@@ -104,3 +105,14 @@ test_wire_plugin_LDADD = \
-ljansson \
libtalerwire.la \
$(top_builddir)/src/util/libtalerutil.la
+
+
+test_wire_plugin_transactions_test_SOURCES = \
+ test_wire_plugin_transactions_test.c
+test_wire_plugin_transactions_test_LDADD = \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ libtalerwire.la \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/util/libtalerutil.la