summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-11-22 23:31:35 +0100
committerChristian Grothoff <christian@grothoff.org>2020-11-22 23:31:35 +0100
commitc0a6e13b3c8bd7a8321bb11fde917869d67dcbc1 (patch)
tree26643c78bcf2a2c58868fc28b0e0e7a89c687b2c /src/util/Makefile.am
parent6082ac8151fd845e65b2222de03b8b10de555f74 (diff)
downloadexchange-c0a6e13b3c8bd7a8321bb11fde917869d67dcbc1.tar.gz
exchange-c0a6e13b3c8bd7a8321bb11fde917869d67dcbc1.tar.bz2
exchange-c0a6e13b3c8bd7a8321bb11fde917869d67dcbc1.zip
first sketch of eddsa helper
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 73edce2cd..5663c6236 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -21,6 +21,7 @@ EXTRA_DIST = \
test_helper_rsa.conf
libexec_PROGRAMS = \
+ taler-helper-crypto-eddsa \
taler-helper-crypto-rsa
bin_SCRIPTS = \
@@ -44,6 +45,15 @@ taler_helper_crypto_rsa_LDADD = \
$(LIBGCRYPT_LIBS) \
$(XLIB)
+taler_helper_crypto_eddsa_SOURCES = \
+ taler-helper-crypto-eddsa.c taler-helper-crypto-eddsa.h
+taler_helper_crypto_eddsa_LDADD = \
+ libtalerutil.la \
+ -lgnunetutil \
+ -lpthread \
+ $(LIBGCRYPT_LIBS) \
+ $(XLIB)
+
lib_LTLIBRARIES = \
libtalerutil.la