summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-11-15 12:13:28 +0100
committerChristian Grothoff <christian@grothoff.org>2020-11-15 12:13:28 +0100
commitb8e35aaed0dc92e1dc1569f0c09ca4e4c36775b9 (patch)
tree15055eec166c73b84c9e010e4ebf1e6000f3def7 /src/util/Makefile.am
parent4f0e38ab12340cea7297fc661c98ddba2d2ef681 (diff)
downloadexchange-b8e35aaed0dc92e1dc1569f0c09ca4e4c36775b9.tar.gz
exchange-b8e35aaed0dc92e1dc1569f0c09ca4e4c36775b9.tar.bz2
exchange-b8e35aaed0dc92e1dc1569f0c09ca4e4c36775b9.zip
add taler-helper-crypto-rsa to build system
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index c25e5700d..991f0a953 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -7,6 +7,8 @@ if USE_COVERAGE
endif
+libexecdir = $(pkglibdir)/libexec/
+
pkgcfgdir = $(prefix)/share/taler/config.d/
pkgcfg_DATA = \
@@ -16,6 +18,9 @@ EXTRA_DIST = \
paths.conf \
taler-config.in
+libexec_PROGRAMS = \
+ taler-helper-crypto-rsa
+
bin_SCRIPTS = \
taler-config
@@ -28,6 +33,13 @@ taler-config: taler-config.in
mv $@.tmp $@
+taler_helper_crypto_rsa_SOURCES = \
+ taler-helper-crypto-rsa.c taler-helper-crypto-rsa.h
+taler_helper_crypto_rsa_LDADD = \
+ libtalerutil.la \
+ -lgnunetutil \
+ $(LIBGCRYPT_LIBS) \
+ $(XLIB)
lib_LTLIBRARIES = \
libtalerutil.la