summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2023-05-10 22:09:47 +0200
committerChristian Grothoff <christian@grothoff.org>2023-05-10 22:09:47 +0200
commitb15713f42e9ecbc67e9b8ffd178d97d08b7377bb (patch)
treeac3e5b4b27372b78a0223201722023e94bb50607 /src/util/Makefile.am
parent495496340554ec4699e9dbc561d921b242c92e6d (diff)
downloadexchange-b15713f42e9ecbc67e9b8ffd178d97d08b7377bb.tar.gz
exchange-b15713f42e9ecbc67e9b8ffd178d97d08b7377bb.tar.bz2
exchange-b15713f42e9ecbc67e9b8ffd178d97d08b7377bb.zip
add helper logic for JSON2JSON conversion
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 115ea5055..9d1ec9d42 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -20,7 +20,8 @@ EXTRA_DIST = \
taler-config.in \
test_helper_eddsa.conf \
test_helper_rsa.conf \
- test_helper_cs.conf
+ test_helper_cs.conf \
+ test_conversion.sh
bin_PROGRAMS = \
taler-exchange-secmod-eddsa \
@@ -80,6 +81,7 @@ libtalerutil_la_SOURCES = \
aml_signatures.c \
auditor_signatures.c \
config.c \
+ conversion.c \
crypto.c \
crypto_confirmation.c \
crypto_contract.c \
@@ -125,6 +127,7 @@ AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=
check_PROGRAMS = \
test_age_restriction \
test_amount \
+ test_conversion \
test_crypto \
test_helper_eddsa \
test_helper_rsa \
@@ -141,6 +144,14 @@ test_age_restriction_LDADD = \
-lgnunetutil \
libtalerutil.la
+test_conversion_SOURCES = \
+ test_conversion.c
+test_conversion_LDADD = \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ libtalerutil.la
+
test_amount_SOURCES = \
test_amount.c
test_amount_LDADD = \