summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-01-14 15:57:36 +0100
committerChristian Grothoff <christian@grothoff.org>2020-01-14 15:57:36 +0100
commit2edee5ac4a4886e71db6e28314334cd24c6d3a55 (patch)
tree944c62dfd7dc9905a58e9888a2239403f4085cd6 /src/util/Makefile.am
parentcba9f8614efab7805d736ac795f8edb970c6a301 (diff)
downloadexchange-2edee5ac4a4886e71db6e28314334cd24c6d3a55.tar.gz
exchange-2edee5ac4a4886e71db6e28314334cd24c6d3a55.tar.bz2
exchange-2edee5ac4a4886e71db6e28314334cd24c6d3a55.zip
refactor uri parsing logic, prepare for unit test
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 89b31ebba..35abe4a1b 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -56,16 +56,16 @@ libtalerutil_la_LDFLAGS = \
-version-info 0:0:0 \
-export-dynamic -no-undefined
-TESTS = \
- test_amount \
- test_crypto \
- test_url
check_PROGRAMS = \
test_amount \
test_crypto \
+ test_payto \
test_url
+TESTS = \
+ $(check_PROGRAMS)
+
test_amount_SOURCES = \
test_amount.c
@@ -79,6 +79,12 @@ test_crypto_LDADD = \
-lgnunetutil \
libtalerutil.la
+test_payto_SOURCES = \
+ test_payto.c
+test_payto_LDADD = \
+ -lgnunetutil \
+ libtalerutil.la
+
test_url_SOURCES = \
test_url.c
test_url_LDADD = \