summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-03-28 22:12:47 +0100
committerChristian Grothoff <christian@grothoff.org>2020-03-28 22:12:47 +0100
commit17eafb869c62f499960c1971a1d6fbfdeda84fc3 (patch)
tree7ebe71b9ca03e2ad0cbffbcf882d3a2804b35675 /src/util/Makefile.am
parent4abb38a36ed41c70e8ee90cda4779c18d42f263b (diff)
downloadexchange-17eafb869c62f499960c1971a1d6fbfdeda84fc3.tar.gz
exchange-17eafb869c62f499960c1971a1d6fbfdeda84fc3.tar.bz2
exchange-17eafb869c62f499960c1971a1d6fbfdeda84fc3.zip
address FIXME
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 55b4fc5ed..4e22f0a08 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -19,6 +19,16 @@ EXTRA_DIST = \
bin_SCRIPTS = \
taler-config
+edit_script = $(SED) -e 's,%libdir%,$(libdir),'g $(NULL)
+
+taler-config: taler-config.in
+ rm -f $@ $@.tmp && \
+ $(edit_script) $< >$@.tmp && \
+ chmod a-w+x $@.tmp && \
+ mv $@.tmp $@
+
+
+
lib_LTLIBRARIES = \
libtalerutil.la