summaryrefslogtreecommitdiff
path: root/src/sq/Makefile.am
diff options
context:
space:
mode:
authorJonathan Buchanan <jonathan.russ.buchanan@gmail.com>2020-06-02 11:57:39 -0400
committerChristian Grothoff <christian@grothoff.org>2020-07-05 16:50:13 +0200
commitef0e79927cbd64832b7351074cf71853212a331b (patch)
tree3177b1949477894d89a9c1cc5ecffa62327f01e0 /src/sq/Makefile.am
parent44c70269e25b86d3ab995b9fbd3366020b6a3c1c (diff)
downloadexchange-ef0e79927cbd64832b7351074cf71853212a331b.tar.gz
exchange-ef0e79927cbd64832b7351074cf71853212a331b.tar.bz2
exchange-ef0e79927cbd64832b7351074cf71853212a331b.zip
created taler_sq_lib
Diffstat (limited to 'src/sq/Makefile.am')
-rw-r--r--src/sq/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/sq/Makefile.am b/src/sq/Makefile.am
new file mode 100644
index 000000000..ee4c5eba7
--- /dev/null
+++ b/src/sq/Makefile.am
@@ -0,0 +1,40 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS) $(SQLITE_CPPFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libtalersq.la
+
+libtalersq_la_SOURCES = \
+ sq_query_helper.c \
+ sq_result_helper.c
+
+libtalersq_la_LIBADD = \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil -ljansson \
+ -lsqlite3 $(XLIB)
+
+libtalersq_la_LDFLAGS = \
+ $(SQLITE_LDFLAGS) \
+ -version-info 0:0:0 \
+ -export-dynamic -no-undefined
+
+TESTS = \
+ test_sq
+
+check_PROGRAMS= \
+ test_sq
+
+test_sq_SOURCES = \
+ test_sq.c
+test_sq_LDADD = \
+ libtalersq.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetsq \
+ -lgnunetutil \
+ -ljansson \
+ -lsqlite3 $(XLIB)