summaryrefslogtreecommitdiff
path: root/src/mint/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-03-20 23:51:28 +0100
committerChristian Grothoff <christian@grothoff.org>2015-03-20 23:51:28 +0100
commit7d9a40327587ed99fb20f4c4a5669069c7a51e48 (patch)
tree40ed8371340ef3d36269e0c9d23c4daae23fb039 /src/mint/Makefile.am
parent0414fb51a9f219c37afc06ad2b309711e360c485 (diff)
downloadexchange-7d9a40327587ed99fb20f4c4a5669069c7a51e48.tar.gz
exchange-7d9a40327587ed99fb20f4c4a5669069c7a51e48.tar.bz2
exchange-7d9a40327587ed99fb20f4c4a5669069c7a51e48.zip
first stab at establishing proper plugin API, main HTTP code compiles, other binaries FTBFS right now
Diffstat (limited to 'src/mint/Makefile.am')
-rw-r--r--src/mint/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/src/mint/Makefile.am b/src/mint/Makefile.am
index 2436d7f37..c4f99af63 100644
--- a/src/mint/Makefile.am
+++ b/src/mint/Makefile.am
@@ -1,18 +1,31 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/pq/ $(POSTGRESQL_CPPFLAGS)
+plugindir = $(libdir)/taler
+
+plugin_LTLIBRARIES = \
+ libtaler_plugin_mintdb_postgres.la
+
+libtaler_plugin_mintdb_postgres_la_SOURCES = \
+ plugin_mintdb_postgres.c
+libtaler_plugin_mintdb_postgres_la_LIBADD = \
+ $(LTLIBINTL)
+libtaler_plugin_mintdb_postgres_la_LDFLAGS = \
+ $(TALER_PLUGIN_LDFLAGS) \
+ -lpq \
+ -lgnunetutil
+
lib_LTLIBRARIES = \
libtalermint_common.la
-# Note: mint_db.c should become a plugin soon! (#3608)
libtalermint_common_la_SOURCES = \
key_io.c key_io.h \
- mint_db.c
+ plugin.c plugin.h \
+ taler_mintdb_plugin.h
libtalermint_common_la_LIBADD = \
$(top_builddir)/src/util/libtalerutil.la \
- -lgnunetutil \
- -lpq
+ -lgnunetutil
libtalermint_common_la_LDFLAGS = \
$(POSTGRESQL_LDFLAGS) \