summaryrefslogtreecommitdiff
path: root/src/mint/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-04-15 22:33:25 +0200
committerChristian Grothoff <christian@grothoff.org>2015-04-15 22:33:25 +0200
commit0baad4430c7f2ee596c05c0eae96b8dfabf7276e (patch)
tree82809256f76e14b597cf33bf85c72fc26ebdbe2e /src/mint/Makefile.am
parent790b331a8d147e4185134483ad4733ea4b5cfdcb (diff)
downloadexchange-0baad4430c7f2ee596c05c0eae96b8dfabf7276e.tar.gz
exchange-0baad4430c7f2ee596c05c0eae96b8dfabf7276e.tar.bz2
exchange-0baad4430c7f2ee596c05c0eae96b8dfabf7276e.zip
preparing to have /test handlers in build system
Diffstat (limited to 'src/mint/Makefile.am')
-rw-r--r--src/mint/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/src/mint/Makefile.am b/src/mint/Makefile.am
index 8d62f67c3..2cda4fac1 100644
--- a/src/mint/Makefile.am
+++ b/src/mint/Makefile.am
@@ -5,15 +5,15 @@ bin_PROGRAMS = \
taler-mint-httpd
taler_mint_httpd_SOURCES = \
- taler-mint-httpd.c \
+ taler-mint-httpd.c taler-mint-httpd.h \
taler-mint-httpd_keystate.c taler-mint-httpd_keystate.h \
taler-mint-httpd_db.c taler-mint-httpd_db.h \
taler-mint-httpd_parsing.c taler-mint-httpd_parsing.h \
taler-mint-httpd_responses.c taler-mint-httpd_responses.h \
- taler-mint-httpd_mhd.c \
- taler-mint-httpd_deposit.c \
- taler-mint-httpd_withdraw.c \
- taler-mint-httpd_refresh.c
+ taler-mint-httpd_mhd.c taler-mint-httpd_mhd.h \
+ taler-mint-httpd_deposit.c taler-mint-httpd_deposit.h \
+ taler-mint-httpd_withdraw.c taler-mint-httpd_withdraw.h \
+ taler-mint-httpd_refresh.c taler-mint-httpd_refresh.h
taler_mint_httpd_LDADD = \
$(LIBGCRYPT_LIBS) \
$(top_builddir)/src/util/libtalerutil.la \
@@ -22,3 +22,8 @@ taler_mint_httpd_LDADD = \
-ljansson \
-lgnunetutil \
-lpthread
+
+if HAVE_DEVELOPER
+taler_mint_httpd_SOURCES += \
+ taler-mint-httpd_test.c taler-mint-httpd_test.h
+endif