summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-07-15 20:55:11 +0200
committerChristian Grothoff <christian@grothoff.org>2019-07-15 20:55:11 +0200
commita497ccffb607c7ac4e6461693630d2d673afff73 (patch)
tree5d7f94f5821b12622fbd78d8332a0d2993ea14fe /src/lib/Makefile.am
parentc1f6115867064d59039c9135842f4fe3c2905ada (diff)
downloadexchange-a497ccffb607c7ac4e6461693630d2d673afff73.tar.gz
exchange-a497ccffb607c7ac4e6461693630d2d673afff73.tar.bz2
exchange-a497ccffb607c7ac4e6461693630d2d673afff73.zip
integrate test for #5777 into build, expected to fail for now
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index c6a1e241c..71301e58d 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -160,6 +160,7 @@ check_PROGRAMS = \
test_exchange_api_keys_cherry_picking \
test_exchange_api_overlapping_keys_bug \
test_exchange_api \
+ test_exchange_api_revocation \
test_auditor_api_version \
test_auditor_api
@@ -190,6 +191,10 @@ AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=
TESTS = \
$(check_PROGRAMS)
+# expected to fail for now: test incomplete, feature not implemented!
+XFAIL_TESTS = \
+ test_exchange_api_revocation
+
test_exchange_api_SOURCES = \
test_exchange_api.c
test_exchange_api_LDADD = \
@@ -204,6 +209,20 @@ test_exchange_api_LDADD = \
-lgnunetutil \
-ljansson
+test_exchange_api_revocation_SOURCES = \
+ test_exchange_api_revocation.c
+test_exchange_api_revocation_LDADD = \
+ libtalertesting.la \
+ libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
test_exchange_api_overlapping_keys_bug_SOURCES = \
test_exchange_api_overlapping_keys_bug.c
test_exchange_api_overlapping_keys_bug_LDADD = \