summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-01-24 18:45:47 +0100
committerChristian Grothoff <christian@grothoff.org>2019-01-24 18:45:47 +0100
commit9de8b7762547e4064d618cf2ad1e4da8a1f6994b (patch)
tree304c1b733a5b3eed64a7ebcad3cac39f4dc4fc74 /src/lib/Makefile.am
parentdabcf7f42e4d15fa86f54e1dbf300c19a9adcb6e (diff)
downloadexchange-9de8b7762547e4064d618cf2ad1e4da8a1f6994b.tar.gz
exchange-9de8b7762547e4064d618cf2ad1e4da8a1f6994b.tar.bz2
exchange-9de8b7762547e4064d618cf2ad1e4da8a1f6994b.zip
adding separate test just for /verison API
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 6f4ffbdf9..b44eccbc8 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -158,6 +158,7 @@ check_PROGRAMS = \
test_exchange_api_overlapping_keys_bug \
test_exchange_api_interpreter_on-off \
test_exchange_api_new \
+ test_auditor_api_version \
test_auditor_api
if HAVE_TWISTER
@@ -257,6 +258,17 @@ test_auditor_api_LDADD = \
-ljansson
+test_auditor_api_version_SOURCES = \
+ test_auditor_api_version.c
+test_auditor_api_version_LDADD = \
+ libtalerauditor.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
+
EXTRA_DIST = \
test_exchange_api_home/.local/share/taler/exchange/offline-keys/master.priv \