summaryrefslogtreecommitdiff
path: root/src/include/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-28 11:34:06 +0200
committerChristian Grothoff <christian@grothoff.org>2015-05-28 11:34:06 +0200
commitde953fa7bcdcfa78606753285911a6a49120327f (patch)
tree203bb8ac7722d260461c656e3f409cf1363f6051 /src/include/Makefile.am
parentc742db86c44c7da89d62b6b4ed031dd4bdf74e38 (diff)
downloadexchange-de953fa7bcdcfa78606753285911a6a49120327f.tar.gz
exchange-de953fa7bcdcfa78606753285911a6a49120327f.tar.bz2
exchange-de953fa7bcdcfa78606753285911a6a49120327f.zip
add --enable-wallet-only flag to build libtalerutil_wallet which ONLY contains the wallet-specific API subset
Diffstat (limited to 'src/include/Makefile.am')
-rw-r--r--src/include/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/include/Makefile.am b/src/include/Makefile.am
index 5bb4cfa20..9c3ee9071 100644
--- a/src/include/Makefile.am
+++ b/src/include/Makefile.am
@@ -1,6 +1,15 @@
# This Makefile.am is in the public domain
talerincludedir = $(includedir)/taler
+if WALLET_ONLY
+talerinclude_HEADERS = \
+ platform.h \
+ taler_amount_lib.h \
+ taler_crypto_lib.h \
+ taler_util_wallet.h
+
+else
+
talerinclude_HEADERS = \
platform.h \
taler_amount_lib.h \
@@ -12,3 +21,5 @@ talerinclude_HEADERS = \
taler_mintdb_plugin.h \
taler_pq_lib.h \
taler_signatures.h
+
+endif