summaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-12-31 22:22:19 +0100
committerChristian Grothoff <christian@grothoff.org>2020-12-31 22:22:19 +0100
commitf82488c060ea980b1da69a022f26658526575547 (patch)
tree0e6c172171075dc4e2c871aa5454ec37d3314b84 /src/exchangedb/Makefile.am
parent0bffea1f67067f56638a36d0b7db30af09d929ac (diff)
downloadexchange-f82488c060ea980b1da69a022f26658526575547.tar.gz
exchange-f82488c060ea980b1da69a022f26658526575547.tar.bz2
exchange-f82488c060ea980b1da69a022f26658526575547.zip
add missing linker options, bonus fun
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 5333cbda5..109ee29a4 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -44,6 +44,7 @@ libtaler_plugin_exchangedb_postgres_la_LDFLAGS = \
$(top_builddir)/src/pq/libtalerpq.la \
$(top_builddir)/src/util/libtalerutil.la \
-lpq \
+ -lpthread \
-lgnunetpq \
-lgnunetutil \
$(XLIB)
@@ -59,7 +60,6 @@ libtalerexchangedb_la_LIBADD = \
$(top_builddir)/src/bank-lib/libtalerbank.la \
$(top_builddir)/src/util/libtalerutil.la \
-lgnunetutil \
- -lpthread \
$(XLIB)
libtalerexchangedb_la_LDFLAGS = \
$(POSTGRESQL_LDFLAGS) \