summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-03-12 10:23:26 +0100
committerChristian Grothoff <christian@grothoff.org>2020-03-12 10:23:26 +0100
commitb91fcbb92f21db498214cba38ffd6e3fe886d95e (patch)
tree18ee0a5b8b28feef17e3ff5aedff490ddc7aebad /src/exchange/Makefile.am
parent83631bc98fe70dd73f212581fb54ab3a82560686 (diff)
downloadexchange-b91fcbb92f21db498214cba38ffd6e3fe886d95e.tar.gz
exchange-b91fcbb92f21db498214cba38ffd6e3fe886d95e.tar.bz2
exchange-b91fcbb92f21db498214cba38ffd6e3fe886d95e.zip
finish separation of aggreator into aggregation, closing and transfer processes (test cases still need to be updated)
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index 227224d30..88753c5e4 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -20,6 +20,7 @@ bin_PROGRAMS = \
taler-exchange-aggregator \
taler-exchange-closer \
taler-exchange-httpd \
+ taler-exchange-transfer \
taler-exchange-wirewatch
taler_exchange_aggregator_SOURCES = \
@@ -59,6 +60,18 @@ taler_exchange_wirewatch_LDADD = \
-lgnunetcurl \
-lgnunetutil
+taler_exchange_transfer_SOURCES = \
+ taler-exchange-transfer.c
+taler_exchange_transfer_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ -ljansson \
+ -lgnunetcurl \
+ -lgnunetutil
+
taler_exchange_httpd_SOURCES = \
taler-exchange-httpd.c taler-exchange-httpd.h \
taler-exchange-httpd_db.c taler-exchange-httpd_db.h \